Forum Discussion

Cory_Blankenshi's avatar
Icon for Altostratus rankAltostratus
Jul 20, 2021

REST API ASM Policy Merge Failing & I Don't Know Why

I'm attempting to merge two ASM policies via the REST API, but the process keeps failing and I'm not sure what the issue is. Here is my process:


- Initiate a policy compare by sending a POST to the .../asm/tasks/policy-diff endpoint, using the self-links to my two policies.

- I send a GET request the self-link of the policy-diff task I just created, which returns the link to the policy differences.


From here, I have tried the following to initiate a policy merge:

- Send a POST to the .../asm/tasks/policy-merge endpoint and reference the policy differences link returned from the previous request

- Send a GET to the policy differences link, which returns the collection of differences and the links to each difference type, so with that...

- Send a POST to the .../asm/tasks/policy-merge endpoint and reference a specific policy difference item link


No matter which option I've tried, the policy merge task fails and returns this error: "Could not execute the Policy Merge Task 'Policy Merge Task (1626807027.135086)'. Diff not found".


According to the documentation, I should be able to initiate a policy merge by sending a POST to the .../asm/tasks/policy-merge endpoint using the following parameters:


policyDiff - This is the link to the differences I want to merge.





*Side-note: the documentation says to use policyDifferenceReference, however that will throw an error because the parameter the API is expecting is actually policyDiff


I haven't the slightest idea why this is failing because what I'm doing is pretty much exactly what the documentation says to do. Has anyone else had this error pop up, or something similar to it? It would be great to hear any thoughts or suggestions anyone has on why this isn't working and/or what I'm doing wrong.


Thanks in advance!

No RepliesBe the first to reply