Forum Discussion

Anju's avatar
Icon for Altostratus rankAltostratus
Nov 25, 2019

winscp error



I have been trying to access some files from the box since we upgraded the code on F5 (, can someone help me understand if it has to do with some settings on F5? if so, how can I fix this? Getting the below error -

Received too large (1936094320 B) SFTP packet. Max supported packet size is 1024000 B. The error is typically caused by message printed from startup script (like .profile). This message may start with "sftp". Cannot initialize SFTP protocol. Is the host running a SFTP server?


Thank you!

8 Replies

  • I remember there is an article for this. Meanwhile, you only encountered this recently, then it's due to the fix at

    You can grant your user Administrator role with Advanced shell access. System-> Users-> username


    For Administrator role w/o Advanced shell access, on wincp, use the SCP protocol + click Advanced

    Environment, select SCP/Shell, for Shell, type bash

    Ok then connect

    • Anju's avatar
      Icon for Altostratus rankAltostratus

      Thank you Samir, unfortunately, this option does not work for me.

  • If you have remote authentication option on F5 you must create local user (named with same as remote user) to connect via sftp.


    Or follow this article;


    • Anju's avatar
      Icon for Altostratus rankAltostratus

      I followed the later article you mentioned for a time being now. Thank you so much. Need to explore the first option though. Do we need to have root privileges to create a local user account? Also, where can we check the rights given to us on the box?


      • Halil_İbrahim's avatar
        Icon for Nimbostratus rankNimbostratus

        If you dont want to solve this problem in winscp side, you should create local user on F5.


        For example; you have AD user named Anju. You will create local user named Anju and give it "advanced shell" right. After that you will login with AD user&pass with "advanced shell" right. ( Only users which have Administrator or User Manager role can create local users)


        To see what is your rights, simply when you login CLI you can not pass to shell with "run util bash" command, Only you will have tmsh access.


        Don't forget that it is workaround solution. On newer software versions users which have not Advanced shell rights can not make sftp connection. And it is by design.