Forum Discussion

Leam_53941's avatar
Leam_53941
Icon for Nimbostratus rankNimbostratus
Mar 07, 2011

Trunk ports for bandwidth and failover?

Is it possible to trunk 2 ports from a 6400 to a Cisco switch so that both wires act as a single wire? This would give us increased bandwidth while both wires worked and would allow redundancy if one wire failed. I know we can trunk on the Cisco switch, but not sure about the BigIP.

 

 

Thanks!

 

 

Leam

 

3 Replies

  • You can configure trunking and even use LACP.

     

     

    From the GUI, it's under Network -> Trunks
  • Hamish's avatar
    Hamish
    Icon for Cirrocumulus rankCirrocumulus
    Be aware that ion the cisco it's called a port-channel. On cisco, a trunk is an interface that handles tagged (802.1q) VLAN's

    On the cisco it should be configured with something like

    
    interface port-channel201
      description port-channel to an F5
      switchport
      switchport trunk encapsulation dot1q
      switchport native vlan 999
      switchport trunk allowed vlan 
      switchport mode trunk
    

    Then on the interfaces themselves you have something like

    
    interface gi3/36
      description F5 interface 1
      switchport
      switchport trunk encapsulation dot1q
      switchport native vlan 999
      switchport trunk allowed vlan 
      switchport mode trunk
      channel-protocol lacp
      channel-group 201 mode active
    

    The native VLAN 999 just allows traffic on a particular VLAN is 802.1q headers are missing. You can add things like spanning-tree portfast etc or other embellishments as required.

    H
  • Below is example config from the bigip_base.conf for an LACP trunk (V10.2):

    
    trunk F5_TRUNK {
       lacp enable
       interfaces {
    3.1
    3.2
       }
    }
    stp instance 0 {
       trunks {
          F5_TRUNK {
             external path cost 20000
             internal path cost 20000
          }
       }
       vlans {
          F5_VLAN
       }
    }
    vlan F5_VLAN {
       tag 10
       trunks tagged F5_TRUNK
    }