Forum Discussion

pdawson1983's avatar
pdawson1983
Icon for Nimbostratus rankNimbostratus
Nov 16, 2017

Default Route into OSPF

I am unable to advertise a default route 0.0.0.0/0 from the F5 into ospf.

I have an F5 VE running 12.1.1 on KVM-QEMU. IMI is running and I have neighbor relationships with the appropriate routers. All other routes that I test are added without issues, but I do not see the 0.0.0.0/0 route being advertised into ospf.

MY ZebOS config:

[root@F5-INTERNET-01:Active:In Sync] config  cat zebos/rd0/ZebOS.conf
!
no service password-encryption
!
interface lo
!
interface tmm
!
interface Core
    ip ospf priority 0
    ip ospf mtu-ignore
!
interface Internet
!
router ospf
 ospf router-id 10.246.3.250
 redistribute kernel
 passive-interface Internet
 network 10.246.3.0 0.0.0.255 area 0.0.0.0
!
line con 0
 login
line vty 0 39
 login
!
end

Here is the LTM Configuration:

ltm virtual /Common/Test {
    destination /Common/0.0.0.0:0
    ip-protocol tcp
    mask any
    profiles {
        /Common/fastL4 { }
    }
    source 0.0.0.0/0
    translate-address enabled
    translate-port disabled
}
ltm virtual /Common/test2 {
    destination /Common/10.10.10.1:80
    ip-protocol tcp
    mask 255.255.255.255
    profiles {
        /Common/tcp { }
    }
    source 0.0.0.0/0
    translate-address enabled
    translate-port enabled
}
ltm virtual /Common/test3 {
    destination /Common/20.20.20.0:0
    ip-protocol tcp
    mask 255.255.255.0
    profiles {
        /Common/tcp { }
    }
    source 0.0.0.0/0
    translate-address enabled
    translate-port disabled
}
ltm virtual-address /Common/0.0.0.0 {
    address any
    arp disabled
    icmp-echo disabled
    mask any
    route-advertisement enabled
    server-scope none
    traffic-group /Common/traffic-group-1
}
ltm virtual-address /Common/10.10.10.1 {
    address 10.10.10.1
    arp enabled
    icmp-echo enabled
    mask 255.255.255.255
    route-advertisement enabled
    server-scope none
    traffic-group /Common/traffic-group-1
}
ltm virtual-address /Common/20.20.20.0 {
    address 20.20.20.0
    arp disabled
    icmp-echo disabled
    mask 255.255.255.0
    route-advertisement enabled
    server-scope none
    traffic-group /Common/traffic-group-1
}

What is the issue?

1 Reply

  • Figured it out. I was missing the default-information originate command.

    The config should look like this:

    [root@F5-INTERNET-01:Active:In Sync] config  cat zebos/rd0/ZebOS.conf
    !
    no service password-encryption
    !
    interface lo
    !
    interface tmm
    !
    interface Core
        ip ospf priority 0
        ip ospf mtu-ignore
    !
    interface Internet
    !
    router ospf
     ospf router-id 10.246.3.250
     redistribute kernel
     passive-interface Internet
     network 10.246.3.0 0.0.0.255 area 0.0.0.0
     default-information originate
    !
    line con 0
     login
    line vty 0 39
     login
    !
    end