Forum Discussion

Sekhar's avatar
Icon for Nimbostratus rankNimbostratus
Feb 07, 2016

F5 upgrade error

Hi All,


I tried to upgrade my F5 VE from 11.5.1 and 11.6.1 and got the following error on reboot.


set.1./var contains a file system with errors, check forced


set.1./var: Directory inode 81930, block 0, offset 0: directory corrupted


set.1./var: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY. (i.e., without -a or -p options) [FAILED]


*** An error occurred during the file system check.


*** Dropping you to a shell; the system will reboot


*** when you leave the shell.


*** Warning -- SELinux is active


*** Disabling security enforcement for system recovery.


*** Run 'setenforce 1' to reenable.


Give root password for maintenance


(or type Control-D to continue):


Please help me in fixing this errors. I am not even able to access UI or terminal.






7 Replies

  • This is fsck (filesystem check) telling you that the /var file system has errors. This situation is most commonly caused by cutting power to the box without shutting down.


    To fix it, you need to have fsck check the disk and fix errors - it is asking you for the root password so that it can do that - did you provide the password ?


  • Hi, did it work? Because i tried it here, and it did not solve the problem.


    [root@!:!] ~ fsck -y /dev/mapper/var fsck 1.39 (29-May-2006) e2fsck 1.39 (29-May-2006) e2fsck 1.39 (29-May-2006) e2fsck 1.39 (29-May-2006) set.1./var: clean, 7366/393216 files, 98325/786432 blocks set.2./var: clean, 6342/393216 files, 97703/786432 blocks set.3./var: clean, 11/393216 files, 28755/786432 blocks [root@!:!] ~


    • Sekhar's avatar
      Icon for Nimbostratus rankNimbostratus
      Hi EduardoRS, I was not able to do it. F5 team didnot provide any solution as I was not able to provide the qkview. They just transferred my license to another VE. Thanks, Sekhar
    • IanB's avatar
      Icon for Employee rankEmployee
      Hi EduardoRS, Did you reboot ('reboot' command) after running fsck ? If not, and if this is a VE, then the fastest resolution may be to just redeploy the OVA file, and then call F5 support to get the license transferred to the new OVA, as Sekhar did.
  • sara_125232's avatar
    Historic F5 Account

    It is File System Error not Disk necessarily.


    enter the root password fsck -A -y shutdown -rF now
  • I did the procedure described in article and solved my problem.

    Log in to the command line.
    To create the / forcefsck file, type the following command:
    touch /forcefsck
    During the next reboot, the / forcefsck file causes the system to perform the file system check.
    If you want to reboot the system at this time, type the following command: