Forum Discussion

Glenn_32974's avatar
Icon for Nimbostratus rankNimbostratus
Mar 18, 2015

HOW-TO disable Microsoft-HTTPAPI /2.0

To the Microsoft Experts out there


This is my (GTM) scenario...


There are two Data Centers


Each Data Center with its own GTM and its own IIS server ( hosted on Windows 2012 server) ( each IIS server hosting the same website or in other words configure with the same application pool)


At the DNS resolution level, GTM works flawlessly.. I have constructed an http monitor validating the host header of the application pool, so when i stop one of the application pool ( in either data center) GTM is capable of detecting the site as "down" and providing DNS response the the one application pool remaining as "up" in the other Data Center. If I do an HTTP capture I can see the "Server" response header with the expected value of "Microsoft IIS 8.5"


up until here all good!


My problem arises at the Browser/user session level


When I go and stop one of the application pool, GTM ( as i said) is capable of detecting the app went down and provides a DNS response to the remaining available site, HOWEVER at the Browser level the user is getting a 503 ERROR message "Service Unavailable". Analyzing the HTTP captures I see the "server" response header with the value of "Microsoft-HTTPAPI / 2.0" as if the IIS is still listening on port 80 for incoming user request


Does anyone knows is this API is related to my problem? If so, how to disable it


I have attached an screenshot for better clarification


Thanks in advanced!



2 Replies

  • maybe it's the web deployment agent service(MsDepSvc)? Try to disable it.


  • The BranchCache (Microsoft) service was binding to port 80 on my system, and running as “Microsoft HTTP/API 2.0″.


    Disabling the BranchCache service released port 80.