Forum Discussion

John_04_141801's avatar
Icon for Nimbostratus rankNimbostratus
Apr 24, 2015

HTTP ERROR: Couldn't open socket connection to server http://....... prior to connect()

Hi Guys:

There is a solution balancing links with two Big-IP 2000s Lik Controller, is working properly. The solution is working with the functionality of the Wide-IPs actually it has 11 wide-IPs and are working well, but there is one that is generating connectivity issues and presents a random error. Apparently this error occurs when large numbers of queries are made.


wsdl error: Getting - HTTP ERROR: Couldn't open socket connection to server prior to connect(). This is often a problem looking up the host name.

I describe the flow Connection of this web service that is having problems.

  1. The user searches the web delegated by the ISP CNAME to F5
  2. The F5 responds with (Wide-IP) and the user shows the website.
  3. The user enters the correct page and authenticates
  4. when you perform a query operation is when a patient presents random error lines shown above.

-FLOW. (ISP-CNAME) >>> (F5) >>> vs_ISP1, vs_ISP2 >>> Pool_APP (1 member)

I really do not know what would be happening, since the service worked fine before configure you as Wide-IP. That is, when only estab configured as virtual server only worked well, but when the wide-ips are set up to be swinging by two bonds (DNS resolution) start these problems.


gtm pool /Common/ {

fallback-mode ratio
load-balancing-mode least-connections
members {
    /Common/ {
        order 0
    /Common/ {
        order 1


Note: I could see that in the wide-IP is configured TTL default (30 seconds). This could be causing me this error on page when making inquiries or information recorded on the website.

I hope some of you can give me some support on this issue that has become critical. Regards. John